Completed
All Done Serivces UP and Running :-)
Posted
1 Nov at 08:41pm CET.
Updated
Test In Progress
Posted
1 Nov at 08:39pm CET.
Updated
We need more time Manitence extended
Posted
1 Nov at 08:38pm CET.
Started
Today the Preventivi Software will be updated with new features.
Posted
1 Nov at 08:25pm CET.
Maintenance